
Essential Google Earth Functions (Retrieved from/modified after
http://serc.carleton.edu/NAGTWorkshops/teaching_methods/google_earth/UserGuide.html. 

The Google Earth User Interface 

When you launch Google Earth, the Earth appears in the 3D viewer within the Google Earth user 
interface, which also includes a set of panes, a menu, a toolbar, navigation controls, and a status bar.  
The 3D viewer shows you aerial and satellite imagery and information about places represented on the 
map as points, segmented lines, polygons, image overlays, photographs, and 3D models.  When the 
terrain layer is activated, the landscape appears in three-dimensional relief. 
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The Google Earth Toolbar 

The Google Earth toolbar contains tools that perform tasks related to the configuration of the user 
interface, the creation of objects to place on the map in the 3D Viewer, recording a tour, showing 
historical imagery, showing sunlight in the 3D Viewer, a ruler for measuring lengths of lines and paths, 
emailing a representation of the 3D Viewer, saving or printing an image of the contents of the 3D 
Viewer, and viewing the data in Google Maps. 

The Google Earth Toolbar offers tooltips that pop up to identify each tool as the mouse passes over it. 
For example, the Hide/Show Sidebar button toggles the visibility of the three panes on the left side of 
the user interface on and off.  The Add Placemark, Add Polygon, Add Path, and Add Image Overlay 
buttons are for creating new data.  The functions of some of these tools are described below.  In 
addition, the Google Earth User Guide identifies the components of the user interface, and offers 
comprehensive information on how to use them.  

Navigation 

Navigation is the process of changing the position of your view of the Earth.  The position of the view 
can be changed through the navigation controls, mouse navigation, key combinations, searching, or 
visiting pre-defined places.  The navigation controls are used to adjust the location of the view, the map 
orientation, the zoom level, and the tilt. 

Drag the ring with the ‘N’ on it to rotate the view.  Click the ‘N’ to orient the globe so that north is at the 
top. 

Keyboard and mouse controls for navigation and other Google Earth techniques differ, in some cases, 
between Windows machines and the Macintosh.  For a list of these controls, see Google's Keyboard and 
Mouse Controls page. 
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Dragging the mouse while the left or right button is held down can also be used to navigate.  To use the 
mouse to pan the 3D Viewer, hold down the left mouse button and drag the view in the direction that 
you would like to move it.  With the right mouse button held down, you can rotate the 3D Viewer 
clockwise by dragging the mouse to the left, and you can rotate it counterclockwise by dragging the 
mouse to the right.  The mouse wheel can be used to navigate as well.  To zoom in with the mouse, turn 
the mouse wheel away from you.  To zoom out with the mouse, turn the mouse wheel down toward 
you.  With the right mouse button held down, you can also zoom in by moving the mouse down, and 
zoom out by moving it up. 

The Google Earth Status Bar 

The Google Earth Status Bar shows the imagery date, latitude, longitude, elevation, and eye altitude of 
the current view.  It is visible at the bottom of the Google Earth User Interface when the Tour Guide is 
closed. 

Searching 

In the Search pane, your can use the three tabs, respectively, to: 
• Search for places
• Get directions
• Show a list of recent searches
• Get directions
• Copy search results to the Google Earth My Places folder
• Copy search results to the clipboard as KML
• Print search results

As the Search pane is pictured here, we have flown to Yosemite National Park, after clicking the Search button. 

Addresses can be specified in a variety of formats.  For example, you can fly to 37.42197, -122.08414.  In 
addition to natural features, you can search for cities, towns, countries, types of businesses, or other types 
of establishments such as schools, airports, churches, temples, mosques, hospitals, or police stations. 
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Working with Places 

 
The Places pane is where third-party data and your own data are listed and organized.  Data that has 
been loaded or created during the current session generally resides in the Temporary Places folder.  
Documents, folders, and placemarks can be dragged to reorganize them in the Places pane. 

A great deal of third-party data is available on the web.  The Google Earth Community and other web 
sites listed below are good sources of this data.  However, in many cases, you may sometimes discover 
that there is insufficient data for a topic that you would like to cover in an educational setting.  One 
remedy is to download the data that exists for that topic and add additional data to it.  In some cases, it 
may be necessary to start from scratch.  But in either situation, it is likely that you will need to: 

• create placemarks to identify particular points on the map, and possibly include descriptive 
information, images, and hyperlinks that appear in an information balloon when the placemark is 
clicked.  For example, a series on rock outcrops can be identified by placemarks, with 
descriptions and close-up photographs placed in the information balloons. 

• draw paths to identify routes or other linear features.  This might be useful for a virtual guided 
tour along a trail. 

• draw polygons to identify or outline areas or features of interest.  Polygons might be used to 
enclose areas of similar soil type or vegetation. 

• overlay maps or specialized aerial imagery on the Google Earth imagery.  For example, a USGS 
topographic map overlay may help interpret a glacial landscape or a series of waterfalls. 

Data that you download or create can be saved within the My Places folder so that it is available in 
subsequent sessions.  You can either drag it into that folder or click Yes, when asked whether to save the 
items that are in the Temporary Places folder in the My Places folder when you exit Google Earth.  
However, it is a good practice to explicitly save your data.  To save an item that is listed in the Places 
Pane, right-click it (ctrl-click on the Mac) and choose Save Place As from the contextual menu that 
appears.  In order to make informed decisions about how to save your data, you need to know 
something about the format of Google Earth data. 
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Google Earth data, including placemarks, paths, polygons, and overlays, consists of KML (Keyhole 
Markup Language) markup that can be saved in text format with a kml file extension, or, most 
commonly, in compressed KMZ format with a kmz file extension.  A kmz file is actually a zip archive 
which contains a doc.kml file with KML code, and possibly other supporting files such as images.  The 
KMZ markup for a place or a container can be viewed by right-clicking it (ctrl-click on the Mac), choosing 
Copy, and pasting it into a text editor. 

Google Earth can open or import a variety of data files, including the standard KMZ and KML formats, as 
well as images (jpg, bmp, tif, tga, png, jpeg, gif, tiff, ppm, and pgm), gps (gpx and loc), and Collada 
models (dae).  Google Earth Pro can open additional formats, including ESRI shapefiles (shp) and 
MapInfo (tab) files.  Once opened in Google Earth Pro, most of these formats can be saved as kmz files, 
which then makes them available to be used in the free version of Google Earth. 

Creating a New Placemark 

To create a new placemark, first navigate to the location in the 3D Viewer where you would like to put 
the new placemark.  Then you can create it by clicking the Add Placemark button on the toolbar or right-
clicking the container listed in the Places Pane in which you would like to put the new placemark, and 
choosing Add, and then Placemark.  There are other means of initiating this process as well.  In either 
case, the New Placemark dialog box will appear. 

While the New Placemark dialog box is open, the information inside can be edited and the placemark 
can be dragged to adjust it to its proper position.  The various tabs can be used to access the placemark's 
properties including its name, description, the icon that is used to represent the placemark in the 3D 
viewer, the color of the icon and the label, and the orientation and zoom level of the 3D viewer that 
results when the placemark is double-clicked in the Places pane.  You can create your own custom icons 
for your placemarks.  Placemarks and other items can be edited after they are created or opened in 
Google Earth.  Right-click (ctrl-click on the Mac) the item in the Places pane or in the 3D Viewer to open 
its Edit dialog box.  While a placemark's dialog box is open, the information inside can be edited and the 
placemark can be dragged. 
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Placemarks can respond to mouse clicks by displaying information balloons that contain text, images, 
hyperlinks, and other structures that can be implemented in HTML.  Information intended for display in 
the balloon should be entered into the Description text area.  Images can be embedded directly into kmz 
files or can be stored on a server, such as Flickr, and referenced via http.  There are advantages and 
disadvantages to each method of offering images. 

It is important that you save your data periodically in a proper manner, so that if a problem occurs, you 
have safe copies of it.  To save data properly, you need to understand how the items in the menu bar 
and pop-up menus function concerning the process of saving data. 

To save an individual placemark, right-click its name (ctrl-click on the Mac) in the Places pane and 
choose Save Place As.  Navigate to a folder where you would like to save the item as a file, give it the 
name you would like, and click the Save button.  Your choices are to save it in KMZ or KML format.  The 
default name for the file is based on the name of the item to be saved, and the default file type 
extension is kmz.  In general, saving the file as a KMZ file is a good choice, because if the placemark 
contains embedded images that reside on a local storage device, copies of those images will be 
incorporated into the KMZ file, minimizing the likelihood that the file will become separated from 
essential content.  It is also a good idea to make backup copies of your saved files. 

Save to My Places is a less secure option, since it moves the placemark to the My Places folder, and 
depends upon Google Earth to save it for a future session.  In a public facility such as a computer 
laboratory, where machines are shared by multiple users, the machines are often configured to log the 
user off after a certain duration of inactivity.  It is possible that the managers of the facility have 
arranged for the My Places folder to be purged of added content when the session terminates. 

It is a good idea to keep multiple copies of KMZ files and any other saved material that you value.  
Folders, documents, paths, polygons, and overlays, which are discussed below, can be saved in a similar 
manner to placemarks. 

The File menu in the Google Earth menu bar provides another means of saving information.  To save a 
feature or container as a file, make sure it is highlighted in the Places or Search pane and choose File → 
Save → Save Place As in the menu bar.  Navigate to a folder where you would like to save the item as a 
file, give it the name you would like, and click the Save button.  This option is risky, since if you have the 
wrong item highlighted you may mistakenly overwrite a needed file with content that you did not intend 
to save. 

Drawing Paths and Polygons 

The Add Path and Add Polygon buttons on the toolbar initiate the process of creating new paths or 
polygons, respectively.  Once the corresponding dialog box opens, you can draw the path or polygon by 
either clicking or left-dragging the mouse.  The tabs in the dialog box provide access to various 
properties.  

86



 
Creating a new path in Google Earth.  Points along the path can be added, dragged, or deleted and the 
information can be changed while the New Path dialog box is open.  The Edit Path dialog box can be 
opened to alter the path after it has been created.  
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Creating a new polygon in Google Earth. Points can be added, dragged, or deleted and the information 
can be changed while the New Polygon dialog box is open.  While editing a polygon, it is a good idea to 
remove its fill so you can see the underlying imagery.  To remove the fill, activate the Style, Color tab in 
the dialog box, and use the pulldown menu for Area to specify Outlined.  The Edit Polygon box can be 
opened to alter the polygon after it has been created.  Note that after you have selected a point in a 
polygon or path by dragging it or just clicking it, the next point you add will be topologically after that 
point.  If you want to continue adding points, instead, after the most recent point you added, you will 
need to reselect that point first. 

As is true of other work that you do, it is important to save your paths and polygons either by saving 
them individually, or by saving the containers, namely folders or documents, in which they reside. 

Elevation Profiles 

Use the path tool to create elevation profiles.  Either create or open an existing path and then choose 
Edit → Show Elevation Profile in the menu bar.  The profile will appear in a new window at the bottom 
of the screen with an arbitrary vertical scale.  Move your cursor to the top of the box and drag it down to 
equalize vertical and horizontal scales to give a profile without vertical exaggeration.  To see the 
elevation and distance at different points along a path, mouse over the path.  To see data for a portion 
of the path, left-click and hold, then move the cursor along the path you want to see. 

Creating Image Overlays 

Digital maps can be added to the Google Image 3D Viewer as image overlays.  They need to be adjusted 
to conform geospatially to the underlying Google Earth imagery. 

To create a new image overlay, first navigate to the location where you would like to place the new 
imagery.  Then click the Add Image Overlay button or right-click the container listed in the Places Pane in 
which you would like to put the new overlay.  There are other means of initiating this process as well. In 
either case, the New Image Overlay dialog box will appear. 
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Use the slider to control the transparency of the image so you can move, rotate, and stretch it, using the 
available green handles, to fit the underlying Google Earth imagery.  Once you are satisfied with it, you 
may make it opaque again.  The tabs allow you to control other properties of the overlay. One of the 
useful settings is the Draw Order which is available in the View tab.  Since overlays cover the area where 
they are situated on the globe when they are visible, they inevitably obscure other overlays that they 
overlap if those overlays are drawn first.  If you have a preference for the order in which overlays in a set 
are drawn, assign low Draw Order numbers to the ones that you would like to appear on top so that 
they are drawn last.  The ones with the highest numbers are drawn first, and get covered up by ones 
with lower numbers if they occupy the same parts of the globe.  Click OK when you are satisfied with the 
overlay's location and other properties. Remember to save your work in a file. 
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While you are creating overlays, it is a good idea to have the Terrain layer deactivated. During the 
creation of overlays of map images that include national or state boundaries, it may be helpful to have 
the Borders and Labels layer active as a guide for adjusting the placement of the image. 

Using Layers 

Google offers a huge amount of mappable data from its database through the Layers Pane.  The growing 
set of layers include roads, volcanoes, 3D buildings, terrain, borders and labels, weather, photographs, 
earthquakes, news, YouTube video, and much more. 

The layers are arranged hierarchically, with some of the layers containing several levels of sub-layers.  To 
expand a layer listed in Layers Pane, so that you can see a listing of its contents, click the + sign to its left. 
You can collapse it later by clicking the - that appears.  As with items in the Search and Places Panes, you 
can control visibility of the layers with their checkboxes. 

The Terrain layer has a special status.  While it is activated, the Earth's landscapes appear in 3D.  This 
especially apparent when the 3D Viewer is tilted so that there is a horizontal component to the user's 
perspective. 
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Organizing Your Work 

Vectors (placemarks, paths, and polygons) and overlays can be organized into containers such as folders 
and documents.  Vector features can be assigned styles, which in the case of placemarks control color, 
opacity, size and the icon, and with paths and polygons, control color, opacity, and thickness of lines. 
Polygons can be filled or outlined. 

Making Sure You Save Your Work Properly 

When saving your work, be sure to specify the container that contains your data as the item that will be 
saved.  When the container is saved in a KMZ file, the contents of the container will be saved along with 
it.  Right-clicking (ctrl-click on the Mac) the item in the Places Pane and choosing the Save Place As item 
in the contextual menu that appears is the best way to save your work because it minimizes the 
likelihood that you will be mistaken about what you have saved. 

The Menus 

Some of the functions of Google Earth can be accomplished through the menu bar at the top of the 
interface. 

The File menu offers options that deal with opening and saving files 

The Save Place As option in the File Menu has a similar function to the Save Place As option in the 
contextual menu that appears when you right-click an item in the Places or Search Pane.  If an item is 
highlighted when you choose this option from the file menu, the dialog box will enable you to save that 
item.  If nothing is highlighted, you may be prompted to save the My Places folder along with its 
contents in the Places Pane.  The hazard with using this option from the File menu is that if you are 
mistaken about what is highlighted, you may not be saving the work that you intended to keep.  There is 
a danger that when you exit Google Earth, your work will be lost.  The safe thing to do is to right-click 
and save the intended item through the contextual menu. 
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The Options item in the Tools menu opens a dialog box that enables you to control many settings for 
Google Earth.  With the five tabs that are available, you can control the units that are used to display 
latitude and longitude, and elevation, the vertical exaggeration of the terrain layer, fonts, tour settings, 
and many other parameters.  On the Macintosh, the Options item is in the Google Earth menu. 
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